Notices

What have I done now?

Closed Thread

Old 01-03-2004, 04:43 PM
  #1  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Mar 2002
Location: Sanford, NC / Cedar Point
Posts: 581
Default What have I done now?

This is long, please hang with me... Went to take the boat out to the lake for a while today just to run it but when I was getting her ready neither of the VHF's would work. Traced that down to corroded wires so I thought I would just run new to the radios. When I started this task everything else controlled by the dask switches worked; bilge pump, nav lights, horn, tabs....now nothing does!!!!! I thought that I might hace knocked the main power lead from the batterys loose but couldn't find anything. Looking at my battery compartment there was what appeared to be a fuse holder coming from my Perko battery switch, heavy ( 8 guage ? ) wire, holder about 3 inches long and 1/2 inch around...well when I pulled ( too hard ) it apart what looked to be a glass fuse came out in peices. Is this really a fuse that can be replaced or a fused link and can it be replaced? Any thoughts on my other problem would be appreciated also. 2004 starting off good for me, truck wouldn't crank either....in tank fuel pump gone out, guess Mr Fixit will try to drop the tank tomorrow
Thanks, David

Capt of the "Last Chance"
(if you only knew)
baileydale is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: