Notices
Marine Electronics Forum

Lowrance Elite 7 Ti

Old 10-24-2019, 11:29 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Oct 2019
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default Lowrance Elite 7 Ti

Morning Everyone
I have recently purchased a used Lowrance Elite 7 Ti . On checking the unit it seems to be almost in brand new visible condition .
Spoke to the previous owner that purchased it for his boat , installed it but never got to use it due to health reasons . Thus also the reason why he is selling the unit .
I switched it and found that it could not find the GPS possition . I further checked and saw that it could not pick up any of the satalite signals.
Did some checks , re-sets , spoke to some people etc. and found that internal GPS module seems faulty as it cant find the Elite 7 Ti GPS on the GPS settings .
Everything else on the unit works great .

The unit is brand new but bordering / just over the 2 year warranty period Lowrance offers . With this trying to get feedback , e-mails etc i wonder if i will ever get any reply . And when i do it would be most probably have expired .Our local Lowrance agents wont help me as the previous owner bought the unit from WaveInn . All the paperwork seems legit and distributed by Nevico .

So i am patiently waiting for feedback on the warranty . And strange enough that my best feedback came from WaveInn till thus far where the unit got purchased . Still waiting for Lowrance .

My questions are :
1. What could have caused the failure ?
2. Can it be repaired ?
3. Who can possibly repair it / what is involved ?
4. Is there any way around it ?

Thank you . Will appreciate any feedback on this matter .

Juan Pretorius

Old 10-25-2019, 04:31 AM
  #2  
Senior Member
 
Join Date: Mar 2013
Posts: 115
Received 5 Likes on 5 Posts
Default

Contact the tech support with the serial number. They will tell you were you stand on the warranty. I would hope it's covered. They are your best bet for repair. Just had to do this myself. Different machine/brand but same company. They were great about getting back to me.
Old 10-25-2019, 04:46 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Oct 2019
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

Thank you Bob
I have contacted Lowrance a week ago will the information and still have no reply . I will try the tech support and see how they respond .
Old 10-25-2019, 05:09 AM
  #4  
M&M
Senior MemberCaptains Club Member
 
Join Date: Feb 2006
Location: Montreal,Quebec & NY
Posts: 992
Received 40 Likes on 38 Posts
Default

Did you look under system - satellites- source?
Old 10-25-2019, 02:35 PM
  #5  
Senior Member
 
Join Date: Mar 2009
Posts: 112
Likes: 0
Received 14 Likes on 8 Posts
Default

The other option is to run it off an external GPS module connected to a NMEA network.
Old 10-27-2019, 05:51 AM
  #6  
Admirals Club Admiral's Club Member
 
Join Date: Jul 2013
Location: N.E. Tennessee
Posts: 370
Received 470 Likes on 199 Posts
Default

I have that same exact unit and it works very well for me. It had old firmware so I updated it which reset all of the settings. You might try to reset it to factory defaults and see what that does. A NIB failure seems unlikely IMHO.

Also, were you outside when you were checking it out? I was recently testing a GPS puck and had it placed right next to windows where I work. It couldn't get a fix which I found surprising. As soon as I took it outside, it got a fix in a few minutes. So make sure that you have a clear sky view.
Old 10-27-2019, 10:48 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Oct 2019
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

Hi M&M
Yes i will take some pics and post them . Then you can see where i am and what i have done .

Regards
Juan Pretorius
Old 10-27-2019, 10:51 PM
  #8  
Junior Member
Thread Starter
 
Join Date: Oct 2019
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

Hi Ausiejake
I am looking at that option as well . But i would like to check all options to repair the unit first if possible .
Would do that as a last resort as my space is very limited .

Regards
Juan
Old 10-27-2019, 10:53 PM
  #9  
Junior Member
Thread Starter
 
Join Date: Oct 2019
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

Hi bakerjw
I have tried it all . I will take some pics and post them later so you can get a better idea of what i am seeing .

Regards
Juan

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.