Notices

Help Needed, Range issues

Old 07-26-2018, 07:40 AM
  #1  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Jun 2002
Location: Treasure Island, FL
Posts: 739
Default Help Needed, Range issues

I need some help from the folks at Fell Marine. I recently installed the system on my boat and used it for a few trips with zero issues. The fob worked exactly as it should at all times during testing and during use. We just got back from a 920mile trip on our boat and it worked perfectly until the last day. For some reason the fob would cut out (at cruising speed which is not fun) multiple times. I was within 2-3 feet from the fob. Being that we were seriously far from our destination, the thought of it malfunctioning made for an uneasy ride back. If I cannot eliminate the issue, I am going to have a hard time continuing to use it on my boat.

For reference:

32' SeaVee with twin Mercury 300 engines.
MOB+ replaced the existing kill switch.
Installed to the exact specifications on the manual.
30+ hours of use without trouble.

Purchased within the last month.

Any help would be greatly appreciated it.
cavitating is offline  
Old 07-26-2018, 07:41 AM
  #2  
Admirals Club Admiral's Club Member
 
Join Date: Jun 2009
Location: Amongst the FL fishies
Posts: 6,696
Default

fob???
airbrush is online now  
Old 07-27-2018, 07:13 AM
  #3  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Jun 2002
Location: Treasure Island, FL
Posts: 739
Default

Not sure I understand your question Airbrush. If you are asking what I am calling the Fob, it is the red pill shaped device that you wear on your wrist or on a lanyard. It is the wireless piece that is worn. If your question is stating that you think it may be the fob, then I am not sure. It worked great as it was new and within a few days started malfunctioning. Could battery life be 30-40 hours of use? It would be great to hear from Fell Marine on this subject.
cavitating is offline  
Old 08-01-2018, 06:12 AM
  #4  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Jun 2002
Location: Treasure Island, FL
Posts: 739
Default

Issue is still not resolved. My unit is rendered useless at this point. All connections have been checked, the fob is simply not working properly and loses contact with the hub often. I am not sure if this product or the company is ready for prime time....

Before you cut a hole in your boat to install this, I would wait for more people to be the guinea pigs so they can work out their issues.
cavitating is offline  
Old 08-02-2018, 01:33 AM
  #5  
Junior Member
 
Join Date: Apr 2018
Location: Fort Lauderdale, Florida
Posts: 28
Default

Hi cavitating,

Thank you for posting in our forum.

We are sorry to hear you have been experiencing troubles.

Your inquiry is received to our support team at support@fellmarine.com and we are working to get your issue resolved as quickly as possible.

Please send us a private message here in the forum to confirm your identity to our support team so that we can ensure we are getting you the help you need.

We take all inquiries very seriously and we will get this case sorted out. If we suspect any malfunction we will get the unit replaced.

The MOB+ is running in thousands of boats every day without problems, and we are working hard to keep it that way.

Thank you for your feedback.


-FELL Marine Team
FELLMarineTeam is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread