Go Back  The Hull Truth - Boating and Fishing Forum > BOATING FORUMS > Dockside Chat
Reload this Page >

Technical question for the HVAC guys

Notices

Technical question for the HVAC guys

Old 05-29-2012, 06:48 PM
  #1  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Jul 2007
Posts: 959
Default Technical question for the HVAC guys

I had a new Heil 120K btu gas furnace and installed along with a 4 ton 2 stage a/c unit. The furnace worked great all winter and now that it is a/c time I am having what I think is a problem with the system. It runs continously. It barely maintains the set temperature. It has a EWC NCM300 controller which I believe is only good for 1 stage cooling. Am I correct on this? It works great for the two stage heat, but, I don not hear it ramp up after 15-20 minutes like it did in the heat mode. I'm no expert, but I believe I am trying to cool a 3000+ square foot house on 2 tons of cooling? I would like to have all my ducks in a row before I call the heating and cooling company. Thanks!
Moby1 is offline  
Old 05-29-2012, 07:04 PM
  #2  
Senior Member
 
Join Date: Nov 2010
Posts: 173
Default

Call the guy who put it in, your under warranty.
Probably low on refrigerant.
Just a guess from way over here?
I Googled your controller, reads like it's a zone control board.
Lazy Cracker is offline  
Old 05-29-2012, 07:16 PM
  #3  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Jul 2007
Posts: 959
Default

It is a zone controller with a timer for the heating stages. Just not sure on the cooling. My guy is coming the end of the week and I just wanted a little info before he got here. Thanks for the reply.
Moby1 is offline  
Old 05-29-2012, 07:22 PM
  #4  
Junior Member
 
Join Date: Mar 2012
Location: Washington DC
Posts: 9
Default

When was system installed? It is not uncommon for systems installed in colder months to require some adjustment prior to initial start up, for the cooling season.
Rehabit is offline  
Old 05-29-2012, 07:29 PM
  #5  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Jul 2007
Posts: 959
Default

It was installed in March and fired up the end of April. All the pressures are good is just seems like there is no second stage.
Moby1 is offline  
Old 05-29-2012, 09:50 PM
  #6  
Senior MemberCaptains Club Member
 
Join Date: Jun 2005
Location: shelby twp MI
Posts: 1,783
Default

Wrong controller. It's only good for one stage of cooling. Says so right in the submittal.

http://www.ewccontrols.com/acrobat/090377a0138.pdf

You can ask your guy about the UCZ4.
tinmarine is offline  
Old 05-30-2012, 06:49 AM
  #7  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Jul 2007
Posts: 959
Default

Thats what I thought! Thanks.
Moby1 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread