Notices

Common Problem(Weed Eater)

Old 03-08-2012, 10:22 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Apr 2011
Posts: 2,483
Likes: 0
Received 2 Likes on 2 Posts
Default Common Problem(Weed Eater)

What cause the primer bulb not to
pick up the gas.Its fairly new 1 years old.

P/U tube appears to be okay any thoughts?
Old 03-08-2012, 11:26 AM
  #2  
Senior MemberCaptains Club Member
 
Join Date: Jul 2006
Location: NJ
Posts: 7,313
Likes: 0
Received 202 Likes on 115 Posts
Default

A hole would prevent it. is it leaking anywhere?
Old 03-08-2012, 12:13 PM
  #3  
Senior Member
Thread Starter
 
Join Date: Apr 2011
Posts: 2,483
Likes: 0
Received 2 Likes on 2 Posts
Default

no gas leaks just a hiss noise
Old 03-08-2012, 01:16 PM
  #4  
Senior MemberCaptains Club Member
 
Join Date: Oct 2006
Location: Downeast, North Carolina
Posts: 6,132
Likes: 0
Received 2 Likes on 2 Posts
Default

Depending on the gas, gas treatment and quality of the hose and bulb, it can go in a year. There's a flap (valve) in the bulb that can fail the day after install with the cheap ones.

How much hose from the bulb to the tank? how old is the hose? is the tank built-in or is it portable with a quick connect?
Old 03-08-2012, 01:44 PM
  #5  
Senior Member
Thread Starter
 
Join Date: Apr 2011
Posts: 2,483
Likes: 0
Received 2 Likes on 2 Posts
Default

1 year old unit
think the tank is built on
Old 03-08-2012, 01:51 PM
  #6  
Senior Member
 
Join Date: Apr 2009
Location: Charleston, SC
Posts: 926
Likes: 0
Received 44 Likes on 22 Posts
Default

Mine had this similar problem.

Pickup was loaded with debris.

Bought a new one, pulled old one out. Right as I pulled the old one out, the tubing split and separated right at the nipple on the motor end. The crack in it wasn't visible until I went to pull it out and it just snapped.

So for mine was two-pronged problem.

Just pick up the kit and replace both weighted pickup and tube.
Old 03-08-2012, 03:30 PM
  #7  
Senior MemberCaptains Club Member
 
Join Date: Oct 2006
Location: Downeast, North Carolina
Posts: 6,132
Likes: 0
Received 2 Likes on 2 Posts
Default

Sorry, I forgot "(Weed Eater)" in the title. Other than the quick connect part, most my answer is applicable. I had the same thing happen on an older weed eater and got a kit from the mfg that included pieces of hose, primer bulb, pick up tube and fittings. It wasn't much money for the kit and it's just as easy to put the weed eater back together with all new parts. There's probably a small crack somewhere.
Old 03-08-2012, 04:06 PM
  #8  
Admirals Club Admiral's Club Member
 
Join Date: Feb 2010
Location: Land O Lakes, FL
Posts: 3,545
Likes: 0
Received 222 Likes on 125 Posts
Default

Leak in bulb, leak in fuel line, ethanol has made line too soft, plugged fuel filter in tank, valve under bulb bad, breather clogged. Thats all I can think of right now.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.