Notices

Lennox iComfort Wifi thermostat

Old 08-11-2020, 11:54 AM
  #1  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Nov 2004
Location: Media, PA and Brigantine, NJ
Posts: 1,225
Received 85 Likes on 64 Posts
Default Lennox iComfort Wifi thermostat

Anybody have one? Mine stopped hooking up to the wifi. It "sees" it, but won't connect. This happened after a power failure. Comcast replaced the gateway in the house because of other connectivity issues with other devices, still no good. Tried different pass words, no dice. Tried "re-setting" the t-stat. Still won't connect. They aren't available retail, have to go through a dealer and they want $745 plus the service call. Tried calling Lennox and they put you on hold. It has a big "foot print" so I am trying to stay with the same size.

Old 08-11-2020, 01:00 PM
  #2  
Senior MemberCaptains Club Member
 
Join Date: Jul 2004
Location: South East Pa
Posts: 9,587
Received 1,008 Likes on 536 Posts
Default

Originally Posted by TimC2520 View Post
Anybody have one? Mine stopped hooking up to the wifi. It "sees" it, but won't connect. This happened after a power failure. Comcast replaced the gateway in the house because of other connectivity issues with other devices, still no good. Tried different pass words, no dice. Tried "re-setting" the t-stat. Still won't connect. They aren't available retail, have to go through a dealer and they want $745 plus the service call. Tried calling Lennox and they put you on hold. It has a big "foot print" so I am trying to stay with the same size.
We got one, last year when we had a new system installed. Tech said download the App it will work fine. After three days of screwing around found out it wouldn't work with my router. I was really annoyed when I found out that was the only one that supposedly works with our Lennox AC system. I made the mistake of not asking if the new system will work with my $100 fully working wifi thermostat
Old 08-11-2020, 01:05 PM
  #3  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Nov 2004
Location: Media, PA and Brigantine, NJ
Posts: 1,225
Received 85 Likes on 64 Posts
Default

Fixed it! Tried another re-set and it seems to be working, even the app is back up and functioning properly.
Old 08-11-2020, 01:06 PM
  #4  
Admirals Club Admiral's Club Member
 
Join Date: Dec 2015
Posts: 716
Received 1,035 Likes on 567 Posts
Default

I have it and don't have issues. You might want to make sure it's trying to hook up to the 2.4 ghz band if you have a dual band router. I don't think they support 5ghz; and if your networks are the same name it could be getting hung up there.
Old 08-11-2020, 01:11 PM
  #5  
Senior MemberCaptains Club Member
 
Join Date: Jul 2004
Location: South East Pa
Posts: 9,587
Received 1,008 Likes on 536 Posts
Default

Originally Posted by TimC2520 View Post
Fixed it! Tried another re-set and it seems to be working, even the app is back up and functioning properly.
You can stop by and fix mine
Old 08-11-2020, 01:41 PM
  #6  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Nov 2004
Location: Media, PA and Brigantine, NJ
Posts: 1,225
Received 85 Likes on 64 Posts
Default

Originally Posted by FASTFJR View Post
You can stop by and fix mine
When you start the hard re-set (touch the "Lennox" name for 5 seconds on the touch screen). It first states some BS about this is for qualified installers only etc. etc. etc., are you sure you want to continue? Then it offers three options: "yes" "no" or "reset". I was pressing "yes" because I wanted to continue but this time I just pushed the reset button and ignored the yes/no options. Took about 10 seconds for a full reset, then I tried to connect the wifi and it worked perfectly.
Old 08-12-2020, 03:06 PM
  #7  
Senior MemberCaptains Club Member
 
Join Date: Jul 2004
Location: South East Pa
Posts: 9,587
Received 1,008 Likes on 536 Posts
Default

Originally Posted by TimC2520 View Post
When you start the hard re-set (touch the "Lennox" name for 5 seconds on the touch screen). It first states some BS about this is for qualified installers only etc. etc. etc., are you sure you want to continue? Then it offers three options: "yes" "no" or "reset". I was pressing "yes" because I wanted to continue but this time I just pushed the reset button and ignored the yes/no options. Took about 10 seconds for a full reset, then I tried to connect the wifi and it worked perfectly.

Thanks!
Old 08-13-2020, 04:15 AM
  #8  
Senior Member
 
Join Date: Jul 2010
Location: Coastal South Carolina
Posts: 2,918
Likes: 0
Received 151 Likes on 108 Posts
Default

Originally Posted by TimC2520 View Post
Anybody have one? Mine stopped hooking up to the wifi. It "sees" it, but won't connect. This happened after a power failure. Comcast replaced the gateway in the house because of other connectivity issues with other devices, still no good. Tried different pass words, no dice. Tried "re-setting" the t-stat. Still won't connect. They aren't available retail, have to go through a dealer and they want $745 plus the service call. Tried calling Lennox and they put you on hold. It has a big "foot print" so I am trying to stay with the same size.
$745 for a tstat???
Old 09-28-2020, 01:58 PM
  #9  
Admirals Club Admiral's Club Member
 
Join Date: Dec 2015
Posts: 716
Received 1,035 Likes on 567 Posts
Default

***UPDATE*** figured I'd just post it here instead of starting a new thread.

Mine stopped connecting to the app sometime last week. I just spent 90 minutes on hold for them to tell me their system is experiencing issues since Friday; and they hope to have it back up today or tomorrow. So if anyone else is having issues, don't waste your time..... at least for the next few days.
Old 09-28-2020, 02:19 PM
  #10  
Senior Member
 
Join Date: Jan 2011
Location: Retired Bizy Livin
Posts: 7,724
Received 1,346 Likes on 953 Posts
Default

Originally Posted by edwardh1 View Post
$745 for a tstat???
Old 09-30-2020, 01:44 PM
  #11  
Senior Member
 
Join Date: Dec 2010
Location: Phoenix, AZ, ex Wilmington, NC
Posts: 1,142
Likes: 0
Received 99 Likes on 52 Posts
Default

It's funny/amazing how much stuff gets fixed by a factory reset.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.