Go Back  The Hull Truth - Boating and Fishing Forum > BOATING FORUMS > The Boating Forum
Reload this Page >

New voltage regulator? Replace with CDI?

Notices
The Boating Forum

New voltage regulator? Replace with CDI?

Old 09-29-2015, 11:55 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Aug 2002
Location: Corte Madera, California
Posts: 142
Likes: 0
Received 0 Likes on 0 Posts
Default New voltage regulator? Replace with CDI?

Hi All,

I believe I need a new voltage regulator on my 1998 Mercury 200 EFI Offshore. I was running in the other day and my tach started jumping around all over the place. The connections to the tach are tight, clean, and dry.

Looked at the wires from the two voltage regulators, one is clear and other other is brown and slightly burned looking. My mechanic suggested replacing them.

Any recommendations on where to order to get it by the end of the week and at a good price?
I came across the below, anyone have experience with them?

Amazon Amazon

Thanks in advance.
Old 09-29-2015, 12:26 PM
  #2  
Admirals Club Admiral's Club Member
THT sponsor
 
williamwallus's Avatar
 
Join Date: Jun 2014
Location: SWFL, Midwest
Posts: 3,445
Received 784 Likes on 437 Posts
Default

yep use cdi 10 minute job
Old 09-29-2015, 01:42 PM
  #3  
Senior Member
Thread Starter
 
Join Date: Aug 2002
Location: Corte Madera, California
Posts: 142
Likes: 0
Received 0 Likes on 0 Posts
Default

Anyone know where I can order one with expedited shipping? All the ones listed on Amazon don't have expedited options. I checked a few eBay stores and the fastest is USPS Priority, I'd rather not risk it. I want to get out on the water this weekend.
Old 09-30-2015, 11:23 AM
  #4  
Senior Member
Thread Starter
 
Join Date: Aug 2002
Location: Corte Madera, California
Posts: 142
Likes: 0
Received 0 Likes on 0 Posts
Default

FYI, I ordered from iboats. Tracking number shows arrival today - pretty good. Now to see if it fixes my problem.
Old 09-30-2015, 11:36 AM
  #5  
Admirals Club Admiral's Club Member
THT sponsor
 
williamwallus's Avatar
 
Join Date: Jun 2014
Location: SWFL, Midwest
Posts: 3,445
Received 784 Likes on 437 Posts
Default

it should that one of the main signs is the jumping tach also high volts while running

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.