Notices
The Boating Forum

Fuel pump problem

Old 05-15-2015, 03:53 PM
  #1  
Junior Member
Thread Starter
 
Join Date: May 2015
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default Fuel pump problem

when I turn ignition key on starboard engine electric fuel pump does not kick on any ideas
Old 05-15-2015, 07:19 PM
  #2  
Senior Member
 
Join Date: Sep 2002
Posts: 272
Received 5 Likes on 2 Posts
Default

Check fuses, voltage at the pump. Smack the pump as it is switched on.
Old 05-15-2015, 09:32 PM
  #3  
Senior MemberCaptains Club Member
 
Join Date: Feb 2003
Location: M.Vineyard, MA
Posts: 14,830
Received 626 Likes on 473 Posts
Default

Can't hurt to mention the engine for which you are seeking help.

Good chance it could be an on-engine pump/relay fuse, but if the suggestions above don't do it , try the Wiggle Test of all the harness wires and connectors near the pump and it's on-engine relay with key on to see if it activates. If it is a blown fuse, check for corroded connections causing increased amp draw.
Old 05-16-2015, 04:37 PM
  #4  
Junior Member
Thread Starter
 
Join Date: May 2015
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks for reply it's a Volvo penta 5.7 gxi

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.