The Hull Truth - Boating and Fishing Forum

The Hull Truth - Boating and Fishing Forum (https://www.thehulltruth.com/index.php)
-   The Boating Forum (https://www.thehulltruth.com/boating-forum-14/)
-   -   Minn kota riptide 36 volt won't anchor lock anymore (https://www.thehulltruth.com/boating-forum/1106657-minn-kota-riptide-36-volt-wont-anchor-lock-anymore.html)

hblac 08-09-2020 06:35 AM

Minn kota riptide 36 volt won't anchor lock anymore
 
As the title says my Minn Kota Riptide 36 Volt 101 lb thrust trolling motor (6 or 7 years old) won't engage anchor mode anymore. This came on suddenly. Is the problem likely just the remote (brand new battery was installed, so it's not that) and can be rectified by replacing the remote with a new one? Is there a method that can reprocess the remote? Or, is the problem likely on the motherboard? Any knowledgeable advice is welcome, anchoring the old fashion way is a PITA for an old fart like me.

B.E. Coyote 08-09-2020 08:23 AM

Not sure if that is a blue tooth motor or not. If it is, you can download an app for your phone that acts as a remote. That could at least help you rule out the remote as a problem,

Smoak352 08-09-2020 09:28 AM


Originally Posted by hblac (Post 13934977)
As the title says my Minn Kota Riptide 36 Volt 101 lb thrust trolling motor (6 or 7 years old) won't engage anchor mode anymore. This came on suddenly. Is the problem likely just the remote (brand new battery was installed, so it's not that) and can be rectified by replacing the remote with a new one? Is there a method that can reprocess the remote? Or, is the problem likely on the motherboard? Any knowledgeable advice is welcome, anchoring the old fashion way is a PITA for an old fart like me.

Mine is doing the same thing but is 1 year old. Getting it fixed now. I will let you know the result next week.

briclark904 08-09-2020 10:31 AM

Is that the only symptom? Can you still steer the motor with the remote? Does the autopilot work?

hblac 08-09-2020 11:25 AM


Originally Posted by briclark904 (Post 13935652)
Is that the only symptom? Can you still steer the motor with the remote? Does the autopilot work?

yes, I can still steer and speed up or slow down which is why I suspect the remote. Maybe dirt has gotten under the buttons or corrosion has occurred.

hblac 08-10-2020 07:27 AM

Anyone??? Ideas?

creditcardguy 08-10-2020 07:33 AM

My Terrova was acting weird, wouldn’t spotlock, delayed steering response. Tried the YouTube “fixes” no luck. Bought a new remote on ebay $120 now it’s good as new again. Apparently it doesn’t take much, mine is 3 years old and I keep the remote indoors. Good luck.

briclark904 08-10-2020 07:43 AM


Originally Posted by hblac (Post 13935765)
yes, I can still steer and speed up or slow down which is why I suspect the remote. Maybe dirt has gotten under the buttons or corrosion has occurred.

Yes, but does the autopilot or any other function involving the GPS work? While you could replace the remote or borrow one and eliminate that, I suspect it may be your GPS. What does your GPS signal strength indicator on the remote show?


All times are GMT -7. The time now is 10:43 AM.

Powered by vBulletin® Version 3.9.3.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.