Notices
The Boating Forum

Another HPDI issue resolved

Old 01-03-2020, 05:38 PM
  #1  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Aug 2012
Posts: 75
Received 6 Likes on 6 Posts
Default Another HPDI issue resolved

Just wanted to post this incase someone has the same year hpdi. Had an issue with my 2010 200 hpdi that was driving me crazy the last few days. Would not rev past 4000 if slowly throttled up and would get stuck at 3500 if I hit it hard off the line. Replaced all filters and spark plugs and VST kept reading 50 psi but still was stuck at 3500-4000 rpm. What drove me crazy was that all the filters looked clean and almost new. Finally I was told about the high pressure pump filters, but couldn’t find a reference to my style pump on the forum. Opened it up and the 2 filters were right there. Turned out one of them was pretty dirty. Changed it out I’m back to normal.



Likes:
Old 01-03-2020, 06:53 PM
  #2  
Senior Member
 
Join Date: Dec 2012
Posts: 398
Received 106 Likes on 51 Posts
Default

Good Job...
Old 01-03-2020, 06:59 PM
  #3  
Admirals Club Admiral's Club Member
 
Join Date: Aug 2013
Location: Beaverdam VA
Posts: 1,275
Received 557 Likes on 318 Posts
Default

Great job! This will definitely help someone.
Old 01-04-2020, 05:33 AM
  #4  
Senior MemberCaptains Club Member
 
Join Date: Nov 2001
Location: Charleston, SC
Posts: 4,254
Received 114 Likes on 70 Posts
Default

Good job. there are also a number of detailed threads on here with photos and instruction for how to change them plus where to locate the filters since Yamaha does not sell them

Mystery filters in Yamaha HPDI Motors

Old 01-04-2020, 05:37 AM
  #5  
Senior MemberCaptains Club Member
 
Join Date: Feb 2001
Location: Newport, RI & Key West, FL
Posts: 4,324
Received 513 Likes on 232 Posts
Default

Mystery filters in Yamaha HPDI Motors

Old 01-04-2020, 09:50 AM
  #6  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Aug 2012
Posts: 75
Received 6 Likes on 6 Posts
Default

Originally Posted by Trayder View Post
Well I stand corrected. That schematic looks like my style pump.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.