Go Back  The Hull Truth - Boating and Fishing Forum > BOATING FORUMS > The Boating Forum
Reload this Page >

150 mercury Optimax. 2007 need some help pls

Notices

150 mercury Optimax. 2007 need some help pls

Old 07-13-2019, 07:12 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Feb 2019
Posts: 13
Default 150 mercury Optimax. 2007 need some help pls

Hi everyone.

Im new to outboards. Have twin 150. I can’t seem to find out what this does. My manual says it’s the water pressure line. Engine runs fine. No beeps. Should I put those cable back together and should be in the cowling ?

Any my advice would be amazing. Thank you all.

Last edited by Varasjohn; 07-14-2019 at 10:08 AM. Reason: Adding picture
Varasjohn is offline  
Old 07-13-2019, 08:44 PM
  #2  
Senior Member
 
Join Date: Jul 2018
Posts: 195
Default

Can’t see the pic
03Scarab29 is online now  
Old 07-14-2019, 04:04 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Feb 2019
Posts: 13
Default

i wish I could figure out how to upload it.
Varasjohn is offline  
Old 07-14-2019, 06:26 AM
  #4  
Member
 
Join Date: Oct 2018
Posts: 83
Default

Originally Posted by Varasjohn View Post
i wish I could figure out how to upload it.
Need 10 posts. If DM me I could upload. I think can post a link to it if posted elsewhere.
lungdoc is offline  
Old 07-14-2019, 08:09 AM
  #5  
Senior Member
 
Join Date: Jun 2006
Posts: 1,394
Default

Can't see a pic, but it's likely your speedo pickup.
tiretired is offline  
Old 07-14-2019, 12:01 PM
  #6  
Junior Member
 
Join Date: Aug 2016
Posts: 19
Default

Here’s a photo of my ‘08 Opti 115 speed pickup (pitot tube). If this is what you’re referring to, no need to hook it up.


Flats_Fisher1 is offline  
Old 07-14-2019, 04:22 PM
  #7  
lwb
Admirals Club Admiral's Club Member
 
Join Date: Apr 2006
Location: Savannah Ga.
Posts: 1,083
Default

Originally Posted by Flats_Fisher1 View Post
Here’s a photo of my ‘08 Opti 115 speed pickup (pitot tube). If this is what you’re referring to, no need to hook it up.


Dime to a Dollar this is what he is talking about
lwb is offline  
Old 07-15-2019, 08:16 AM
  #8  
Junior Member
 
Join Date: Jul 2019
Posts: 1
Default

here is a link to my problem marineengine.com/boat-forum/showthread.php?457581-2007-mercury-150-optimax
jjvaras is offline  
Old 07-16-2019, 06:39 AM
  #9  
Junior Member
Thread Starter
 
Join Date: Feb 2019
Posts: 13
Default


here is what I have no idea is. lol thanks for all the help and support guys
Varasjohn is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread