Notices

Sloppy Rotary Steering

Old 06-15-2019, 12:02 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Apr 2018
Posts: 13
Default Sloppy Rotary Steering

I seem to have a fair bit of slop in my steering. Its a Teleflex single rotary helm about 20 years old. I replaced the cable 2 seasons ago. Pretty sure I'm going to replace it with the NFB 4.2 Helm. How much play is normal for these steering systems? It's on a 21' SeaPro with a new 150hp Mercury. See video!


Thank!
Buddee is offline  
Old 06-15-2019, 12:09 PM
  #2  
Senior MemberCaptains Club Member
 
Join Date: May 2005
Location: Seattle, WA
Posts: 7,817
Default

Time to replace. No need to put up with that. New system cost about $200

...and to be clear, but the entire system, not just the helm.
Tom W Clark is offline  
Old 06-15-2019, 12:47 PM
  #3  
Senior MemberCaptains Club Member
 
Join Date: Feb 2003
Location: M.Vineyard, MA
Posts: 14,080
Default

If you don't have NFB helm now , you will appreciate the upgrade if you don't opt for better hydraulic system. .
But in the meantime, check to see how much of that play may be loose linkage connection between cable end and engine steering arm.

A lot of that type of slop is from trying to force a semi-seized ( previous in this case) cable to move for too long and helm parts get worn or loose. . In some cases one can open the helm and tighten things to help ( with the new smooth-moving cable.).

Last edited by TTaxi; 06-15-2019 at 12:54 PM.
TTaxi is offline  
Old 06-15-2019, 03:35 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Apr 2018
Posts: 13
Default

Play is definitely at helm. No movement at motor. In the video all that movement never caused any movement at motor. Guessing the gears must be gone in the rotary or maybe a bushing? In any case guess I'll slap a new one on.

Last question...how much play should I expect when it's replaced.
Buddee is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread