Notices

Garmin 7212 device problem

Old 11-04-2019, 05:59 PM
  #1  
Admirals Club Admiral's Club Member
Thread Starter
 
2tofly's Avatar
 
Join Date: Jun 2011
Posts: 182
Likes: 0
Received 0 Likes on 0 Posts
Default Garmin 7212 device problem

Have a 7212 with a GSD 26, GPS 19x NMEA 2000, and a GXM 51. Has worked well for years but suddenly the 19x and the 51 are not functioning and do not appear on the device list. The GSD 26 appears on the list and is functioning properly. It is networked separately from the NMEA 2000 so the problem is only with the NMEA 2000 devices. Checked fuses, connections and power to the backbone. Each device is also getting power through its individual drop cable. Seems unlikely both would fail at the same but it’s possible. I need to find someone in the Lower Keys with one or the other willing to let me hook it up in order to confirm or eliminate the “pucks” as the problem. Has anyone experienced an issue like this that turned out to be the chart plotter itself?
Thanks,
Mark
Old 11-04-2019, 06:03 PM
  #2  
Admirals Club Admiral's Club Member
Thread Starter
 
2tofly's Avatar
 
Join Date: Jun 2011
Posts: 182
Likes: 0
Received 0 Likes on 0 Posts
Default Sorry posted in wrong forum

Fat fingered the post! Mods please move to electronics forum, thanks
Old 12-21-2019, 08:41 AM
  #3  
Junior Member
 
Join Date: Dec 2019
Posts: 10
Likes: 0
Received 2 Likes on 1 Post
Default

Did you find the fix?
Old 12-22-2019, 05:35 PM
  #4  
Admirals Club Admiral's Club Member
Thread Starter
 
2tofly's Avatar
 
Join Date: Jun 2011
Posts: 182
Likes: 0
Received 0 Likes on 0 Posts
Default

Sure did, after shooting eveything the first time, went back to square one starting with the yellow NMEA power wire. Turns out it had a broken wire, would read good and then I would move it around and would show no continuity. Replaced it and everything works just fine now. Thanks for asking.
Mark

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.