Thread: Suzuki issues
View Single Post
Old 02-04-2019, 07:56 PM
  #55  
Saltgod
Admirals Club Admiral's Club Member
 
Join Date: Dec 2015
Location: Augusta, GA
Posts: 122
Default

Originally Posted by GaryCrow View Post
They're implying that the motor was sunk, which it clearly was not or it would not be running. I don't see that any of the circumstances you outlined apply unless he'd opened up the crankcase himself, the crank wasn't exposed to any of the factors they list as denying warranty for corrosion. If it's got corrosion it was put in that way or it's because their seal, which is covered under warranty, leaked and let salt water in. A crankshaft that's been bathed in oil can sit for 50 years and not corrode, plenty of vehicles that have been sitting in barns run after pouring in some fresh gas and a shot of ether.

The dealer took no pictures of the supposed rust and didn't bring it up to the customer when they replaced the seal. Now after their new seal installation fails they suddenly remember there was rust on the crankshaft and they're saying he sunk the motor and that caused it, that's BS. They did an improper installation and it failed, they need to fix it. If it truly was rust on the crankshaft then they should have told him it wasn't repairable the first time, but they didn't.

He's right, he's getting the runaround.
That basically sums up all of the events. Not being a marine mechanic I can figure out how a oil covered crank shaft can even rust or corrode. Or IF it was that bad why not bring it up during the tear down why it wasn't brought to my attention or Suzuki. And why they are defensive about me causing enough stink to get a rep to come look at it.
Saltgod is offline