The Hull Truth - Boating and Fishing Forum

Go Back   The Hull Truth - Boating and Fishing Forum > BOATING FORUMS > Marine Electronics Forum
Search

Notices

Random Quote: Killing's my business and business is good!
Reply
 
Thread Tools Search this Thread
Old 06-11-2013, 01:52 PM
  #1    
Senior MemberCaptains Club Member
 
Join Date: Jun 2003
Location: CovingtonLA
Posts: 671
Default Garmin 492 problem

not working - heard a beep when I tried to turn it on and nothing. attached to the same battery as my radio - that came on. not sure if the display is just not showing or what.

called Garmin and they suggested either check the power for voltage as this unit is sensitive to low voltage or a 'hard reboot'. anyone else with a suggestion please chime in.

went to local West Marine yesterday to look at new units and the only one interesting to me is the 740 - $1K is too much for me. the 54x series is discontinued according to them - I want at least that large screen is I have to buy new(er).
__________________
'87 BW Montauk 17
'13 Evinrude E-Tec 115
bear685 is offline   Reply With Quote
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 



©2009 TheHullTruth.com

Powered by vBulletin® Version 3.7.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0