The Hull Truth - Boating and Fishing Forum

Go Back   The Hull Truth - Boating and Fishing Forum > BOATING FORUMS > Marine Electronics Forum
Search

Notices

Random Quote: I don't drink anymore, but then I don't drink any less either!
Reply
 
Thread Tools Search this Thread
Old 02-25-2007, 06:01 PM
  #1    
Senior MemberCaptains Club Member
 
Join Date: Aug 2004
Location: Chapin, SC
Posts: 197
Default Lowrance lgc 2000 Not responding HELP !!

Here is the Scoop:

1.) Hooked up the Lgc 2000 to my LCX 111HD Ver 1.4. I think it was working correctly, It was trying to acquire satellites but under my shed so it could not.

2.) I was told that the lgc 2000 needed the latest drivers so i tried to install the V 1.9 drivers for it. I do not think the install was successful and now the 111 cannot see the LGC on the network. Module not responding or something like that.

3.) Is there any way to remove the LGC 1.9 V of the drivers and go back to an earlier version?

4.) I have now installed the latest 111 drivers ( V1.7 ) and tried a master reset with no success.


Any help would be greatly appreciated!!



Troy
__________________
99 Grady White 223 Tournament / Yamaha 225 OX66
02 G3 1860 CC / 70 Yamaha
awscwi is offline   Reply With Quote
Old 02-25-2007, 06:37 PM
  #2    
Admirals Club Captains Club Member
THT sponsor
 
Join Date: Feb 2001
Location: Bar Harbor, Maine
Posts: 2,108
Default Re: Lowrance lgc 2000 Not responding HELP !!

Is there anything else on the network and is it working? Are you sure you have power to the network either by the separate power lead coming from the LCX111 (check it's fuse) or a separate power node on the network?
__________________
Gary Cabit
Lake & Sea Boatworks
Bar Harbor, Maine
www.lakeandsea.com

Factory authorized dealer for Suzuki, Nissan & Tohatsu outboards, and Key West & Seaway boats, and Seastar EPS/Optimus 360 Steering Systems.

Please, no tech questions by PM, email or phone.
lakensea is offline   Reply With Quote
 
Old 02-25-2007, 06:44 PM
  #3    
Senior MemberCaptains Club Member
 
Join Date: Aug 2004
Location: Chapin, SC
Posts: 197
Default RE: Lowrance lgc 2000 Not responding HELP !!

The LGC is the only thing on the network.

Power is hooked up in a butt connector with the 111. So if the 111 is on the network should have power.

I think this is a software thing, but it has me stumped.

Troy

__________________
99 Grady White 223 Tournament / Yamaha 225 OX66
02 G3 1860 CC / 70 Yamaha
awscwi is offline   Reply With Quote
Old 02-25-2007, 06:45 PM
  #4    
Senior MemberCaptains Club Member
 
Join Date: Feb 2006
Location: North NJ & Barnegat Bay
Posts: 6,126
Default Re: Lowrance lgc 2000 Not responding HELP !!

check your battery. If its below 12 volts your unit will still turn but your antanna needs a minimum of 11.8 or something like that. Look at your owners manual. It happend to me when i had my lowrance gps wired to one of my trolling motor batteries. I was good to go when o moved the wiring over to the starting battery.
__________________
2006 Skeeter ZX24 Bay
2006 Yamaha 300 HPDI
I love my Yamabomb
2013 Ford F-150 XLT ECO
Team: EAT-SLEEP-FISH---~ <)))))<
Trying hard to become a 1%er
pastaman1234 is offline   Reply With Quote
Old 02-25-2007, 06:51 PM
  #5    
Senior MemberCaptains Club Member
 
Join Date: Aug 2004
Location: Chapin, SC
Posts: 197
Default RE: Lowrance lgc 2000 Not responding HELP !!

Battery is showing 12.4 V on the 111.

__________________
99 Grady White 223 Tournament / Yamaha 225 OX66
02 G3 1860 CC / 70 Yamaha
awscwi is offline   Reply With Quote
Old 02-25-2007, 08:04 PM
  #6    
Senior MemberCaptains Club Member
 
Join Date: Jul 2006
Location: Ellensburg / Sekiu
Posts: 923
Default Re: Lowrance lgc 2000 Not responding HELP !!

Reinstall the software driver and check the power to the module.
Make sure the 111 knows it is there. Check under the menu in the map page for nmea 2000 and see if it is listed.
__________________
I'm out of Beer !!!!
edyer is offline   Reply With Quote
Old 02-25-2007, 09:07 PM
  #7    
Senior MemberCaptains Club Member
 
Join Date: Jul 2006
Location: nhills area. N.C.
Posts: 2,152
Default Re: Lowrance lgc 2000 Not responding HELP !!

The GPS antenna and network should have its own power source, otherwisw it will be on constantly. The head unit should also have its own switched power source IIRC. Check your installation manual.
CAP1 is offline   Reply With Quote
Old 02-25-2007, 09:29 PM
  #8    
Senior MemberCaptains Club Member
 
Join Date: Aug 2004
Location: Chapin, SC
Posts: 197
Default RE: Lowrance lgc 2000 Not responding HELP !!

Thanks for all of the help thus far guys, The weird thing is it acted like it was working ( IE trying to acquire sat. ) before trying to install the V1.9 LGC update.

I guess I will give customer no service a call and hop for the best .

Troy
__________________
99 Grady White 223 Tournament / Yamaha 225 OX66
02 G3 1860 CC / 70 Yamaha
awscwi is offline   Reply With Quote
Old 02-25-2007, 09:57 PM
  #9    
Senior Member
 
Join Date: Sep 2005
Location: Freehold/Cape May, NJ
Posts: 706
Default Re: Lowrance lgc 2000 Not responding HELP !!

I had the same exact thing happen when I tried to upgrade the lgc 2000. Software got hung up mid installation. Afterwards, it wouldn't find the antenna. If I remember correctly, I did a factory reset (in the manual) on my 111 and it worked like a charm. Give it a shot.
__________________
Allie B
2014 27' Sea Hunt Gamefish
Fluka Brasi is offline   Reply With Quote
Old 02-26-2007, 02:43 PM
  #10    
Senior MemberCaptains Club Member
 
Join Date: Jan 2006
Location: Knoxville,TN
Posts: 289
Default RE: Lowrance lgc 2000 Not responding HELP !!

I had the same thing hapen to me when I tried to upgrade the antenna. I asked Lowrance to mail me a shipping label and then sent the entire thing to them. They sent me back a new antenna in 2 days.
davidridenour is offline   Reply With Quote
Old 02-26-2007, 03:06 PM
  #11    
Senior Member
 
Join Date: Aug 2006
Location: marysville wa
Posts: 1,033
Default Re: Lowrance lgc 2000 Not responding HELP !!

i have been haveing the same issues , if you read your manual make shure you hook up all ground shields ect , and what i have found that works is where my lgc 2000 is pluged in at on my mast i unplug the connector and plug it back in turn the unit on and then it responds good luck
a i also have a garman plotter and it never loses signal ever . good luck
__________________
If its on the back it better be mecury black because the race never ends .

2 stroke because 4 strokes are 2 to many and 1 is not enough

yes your suzuki has tons of toqure because its geared high enough to make a weed eater pull a house .!!!! Did you change your oil yet boy ???
lugger is offline   Reply With Quote
Old 02-26-2007, 03:12 PM
  #12    
Senior MemberCaptains Club Member
 
Join Date: Jan 2006
Location: Knoxville,TN
Posts: 289
Default Re: Lowrance lgc 2000 Not responding HELP !!

Quote:
lugger - 2/26/2007 2:06 PM

i have been haveing the same issues , if you read your manual make shure you hook up all ground shields ect , and what i have found that works is where my lgc 2000 is pluged in at on my mast i unplug the connector and plug it back in turn the unit on and then it responds good luck
a i also have a garman plotter and it never loses signal ever . good luck

lugger, sounds like you are having a shielding problem inside the antenna. Are you running radar or near a boat using it or a radar station?They had a problem with radar shielding a while back but only fixed the problems as they were reported. Might be worth a talk to Lowrance.
davidridenour is offline   Reply With Quote
Old 02-26-2007, 03:48 PM
  #13    
Senior Member
 
Join Date: Aug 2006
Location: marysville wa
Posts: 1,033
Default Re: Lowrance lgc 2000 Not responding HELP !!

I had the smaller lowarance with same atenna , no issues
when i upgraded is when i started loosing signal . after connecting the grounds better .
I was out for about 2 hours yesterday and only lost it 2wice , the ground is on the back of my engine gauges . witch will go away and ill hook it up to a better ground if my 250 pro xs ever shows up .
On the rough day before i hooked up the whit wire and the shield wire i lost it for the hole day . i am woundering if water is gettin the connector plug on my mast . i am going to heat shrink it this week end
__________________
If its on the back it better be mecury black because the race never ends .

2 stroke because 4 strokes are 2 to many and 1 is not enough

yes your suzuki has tons of toqure because its geared high enough to make a weed eater pull a house .!!!! Did you change your oil yet boy ???
lugger is offline   Reply With Quote
Old 03-06-2007, 08:50 PM
  #14    
Senior MemberCaptains Club Member
 
Join Date: Mar 2006
Location: Charleston,SC
Posts: 131
Default Re: Lowrance lgc 2000 Not responding HELP !!

I had the same problem, the thing you have to remember is the gps antenna has its own power and ground wires. Once I did that it worked perfectly.
__________________
www.saltytailscharters.com
2007 Dodge 2500 Cummins (Tow Rig)
2010 Scout 221 Winyah Bay
2010 Yamaha 250 VMAX SHO
boatcapt is offline   Reply With Quote
Old 03-06-2007, 09:02 PM
  #15    
Senior MemberCaptains Club Member
 
Join Date: Aug 2004
Location: Chapin, SC
Posts: 197
Default RE: Lowrance lgc 2000 Not responding HELP !!

Lowrance said send it in so I did, we will see what happens. I think I have covered all of the obvious problems, but hey sh!t happens. I guess I will know soon enough as lowrance plans on installing new software on the LGC 2000.

Thanks for all of the input, I Will post the results asap.

Troy
__________________
99 Grady White 223 Tournament / Yamaha 225 OX66
02 G3 1860 CC / 70 Yamaha
awscwi is offline   Reply With Quote
Old 03-06-2007, 09:59 PM
  #16    
Senior MemberCaptains Club MemberPLEDGER
 
Join Date: Feb 2004
Location: Atlanta, GA
Posts: 5,736
Default Re: Lowrance lgc 2000 Not responding HELP !!

I think the problem might be that you are in the shed....did you try pulling the boat out?

If you go to the status screen and its trying to acquire satellites, then the issue is not whether or not you have power. The antenna will give a GPS module not responding message if you have no power to the network.

Also, you don't want to go backwards software wise....the 1.9 is an improvement over 1.7.

Try getting that antenna out to where it has a clear view of the sky, try it again and let us know.
__________________
Too many to list - all have been sold.
Parthery is offline   Reply With Quote
Old 03-06-2007, 11:21 PM
  #17    
Junior Member
 
Join Date: Feb 2007
Location:
Posts: 27
Default Re: Lowrance lgc 2000 Not responding HELP !!

I had the same trouble last year when I went to upgrade. If you get the message, "GPS Not Responding" then there is a problem with the Antenna. On my 111 it was the power cord from the Antenna. The new one fixed the problem. Funny though, when I checked the old power cord it was sending 12 volts, but I guess not enough current was getting through. The new antenna and power cord should fix the problem.
MajorMike is offline   Reply With Quote
Old 03-15-2007, 07:40 PM
  #18    
Senior MemberCaptains Club Member
 
Join Date: Aug 2004
Location: Chapin, SC
Posts: 197
Default RE: Lowrance lgc 2000 Not responding HELP !!

Update:

I received a new lgc 2000 from lowrance yesterday. I hooked it up today and the problem is solved.

I had to pay shipping to Lowrance which I did not like, but who said life is easy ?

Troy
__________________
99 Grady White 223 Tournament / Yamaha 225 OX66
02 G3 1860 CC / 70 Yamaha
awscwi is offline   Reply With Quote
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Lowrance LGC 2000 GPS problem BandDad Marine Electronics Forum 25 03-08-2009 05:58 PM
Looking for a lowrance LGC 2000 antenna DEWORM Fishing & Miscellaneous Items -- COMMERCIAL sellers only 2 06-02-2007 08:43 PM
Looking for a lowrance LGC 2000 antenna DEWORM Marine Electronics Forum 3 03-02-2007 02:09 PM

 



©2009 TheHullTruth.com

Powered by vBulletin® Version 3.7.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0