The Hull Truth - Boating and Fishing Forum

Go Back   >
Search


Reply
 
Thread Tools Search this Thread
Old 07-31-2013, 07:27 PM   #1
Senior Member
Thread Starter
 
Join Date: Apr 2013
Location: Houston,Tx
Posts: 583
Default Please help with Rule 700 livewell pump

After going out Sunday, I noticed I was taking a bit of water. After inspecting everything, I noticed my livewell motor was popped off. I'm trying to find a complete unit with housing but can not find anything that looks just like mine. Again, it's a rule 700 that popped off....any help is much appreciated









lazy21 is offline   Reply With Quote
Old 07-31-2013, 07:50 PM   #2
Admirals Club
 
Join Date: May 2013
Location: Clearwater Fl/ Gainesville Fl
Posts: 4,762
Default

I had the same pump that went out and the housing was cracked. I believe I paid 50 bucks at west marine for a new complete 800gph livewell pump.
linesider 159 is offline   Reply With Quote
Old 07-31-2013, 08:06 PM   #3
Senior Member
Thread Starter
 
Join Date: Apr 2013
Location: Houston,Tx
Posts: 583
Default

Was it a straight drop in pump? Thanks......I've failed on my google fu
lazy21 is offline   Reply With Quote
Old 07-31-2013, 08:19 PM   #4
Admirals Club
 
Join Date: May 2013
Location: Clearwater Fl/ Gainesville Fl
Posts: 4,762
Default

I had to buy a couple adapters so the total was just over 50 bucks. It was very easy replacement though. They have them at west marine but ebay is where I got mine.
linesider 159 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 10:40 AM.


©2009 TheHullTruth.com

Powered by vBulletin® Version 3.9.3.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.