Marine Electronics Forum - Lowrance HDS-5x

THE HULL TRUTH is the world's largest FREE network for the discussion of Boating & Fishing. Whether you're researching a new boat, or are a seasoned Captain, you'll find The Hull Truth Boating & Fishing Message Forum contains a wealth of information from Boaters and Sportfishermen around the world.




View Full Version : Lowrance HDS-5x


jallen5253
03-29-2012, 09:02 PM
I just bought the Lowrance HDS-5x fish finder and installed it on the front deck of my aluminum bass boat. The installation went fine, don't have any thing to hook the yellow wire up to yet but may add the downscan later. After putting everything back together its time for the moment of truth, it powers up and I go through the pages, and watch the simulation. Had the unit on maybe 5 minutes and shut it off. Hey, it's time to hit the water, so I headed to the lake the very next morning. Turned the unit on after I cranked the engine and motered to my fishing spot. I was putting my poles out when I looked down at the fish finder and it was off. I tried to turn it back on but all it would do is flash on for a second and then go black. After trying several times with it just flashing on for a second, then it would not do anything. Left it alone for an hour or so and tried it again, this time it just flashed on like before. Got home, same thing. Now, to my knowledge it didn't get wet, but may have had a drop or two from lifting the rods out of the water. What could be wrong and what can I do?


abbor
03-30-2012, 12:15 AM
It seems to be something wrong with the 5x unit itself. But since you wrote about the yellow wire and you have an aluminum boat it made me thinking about one possible problem. Is the end of the yellow wire isolated such that it don't get in contact with the hull or any other point carrying ground potential?



Search Engine Friendly URLs by vBSEO 3.2.0