Marine Electronics Forum - Garmin Sonar problems

THE HULL TRUTH is the world's largest FREE network for the discussion of Boating & Fishing. Whether you're researching a new boat, or are a seasoned Captain, you'll find The Hull Truth Boating & Fishing Message Forum contains a wealth of information from Boaters and Sportfishermen around the world.




View Full Version : Garmin Sonar problems


Jason520
06-23-2009, 01:41 PM
My Garmin Sonar seems to be on the fritz all of the sudden. It was fine the other day now when I get into depth (105 plus) I have lost detail. (Same fishing spot as two days ago) I can just make out some bottom contour (in just red) but not like it should be marking with the reds, greens and yellows. Where did it go?? Then when I put in in gear (idle) I see even less, like I am running 35 knots. I am also getting these vertical "interference" bars evenly spaced scrolling across the screen. The numerical depth reading in the corner....gone it won't even read. I have been told maybe a ground or power issue. I checked all the connections in the console and everything "looks" ok. I know the transducer is "clicking". Can a transducer start going bad?? Can it start loosing transmitting power?? Whats up here....


rwidman
06-23-2009, 02:49 PM
............ I know the transducer is "clicking". Can a transducer start going bad?? Can it start loosing transmitting power?? Whats up here....

What transducer and where and how is it mounted?

What happens when you shut the engine off?

Jason520
06-23-2009, 08:29 PM
It is a Thru-Hull mount with a fairing block. It is and AirMar transducer. I don't know which model though it came with the boat I purchased. Connected to a Garmin 2010C.
Now that you mention it, I was turning the engines off to get a little better picture. So yes, the picture does improve slightly when I turn them off.....




Search Engine Friendly URLs by vBSEO 3.2.0